Reading Rom Issues

Discussion related to the 4G69 powered Lancer Rallairt
Post Reply
darewood
Posts: 18
Joined: Mon May 07, 2012 10:59 am

Reading Rom Issues

Post by darewood » Fri Jun 01, 2012 3:48 pm

I tried searching the forum before posting, but I'm currently having issues reading the rom on my 2006 Ralliart. First it sometimes doesn't connect to the ECU, then I guess it eventually does but when I go to read the rom it gives this error.

Unable to establish flash loader connetion.

Am I doing something wrong, everything is connected. The car is on, and I have the correct drivers. I'm using windows 7.

hackish
Site Admin
Posts: 598
Joined: Wed Jan 05, 2011 1:49 pm

Re: Reading Rom Issues

Post by hackish » Sat Jun 02, 2012 6:04 am

Did we move that wire under the dash on your car? Is it possible that it became disconnected? I honestly don't remember.

-Michael

darewood
Posts: 18
Joined: Mon May 07, 2012 10:59 am

Re: Reading Rom Issues

Post by darewood » Sat Jun 02, 2012 8:14 am

It's fine, you can't remember every customer. Well I had a mail-in flash so I never came to personally see you, so my wire was never moved. I see in another post it talks about "there is an orange wire spliced from the green wire in the white connector to a pin in the OBD2 port". Now I bought the reflash connector also when I bought the tactrix. Would I have to move that wire still?

hackish
Site Admin
Posts: 598
Joined: Wed Jan 05, 2011 1:49 pm

Re: Reading Rom Issues

Post by hackish » Sat Jun 02, 2012 8:40 am

With the reflash connector it can be made to work. Initially it would be quicker for you to just to splice the wire. It's Pin 11 on the OBD2 connector. Depending on your lancer they're sometimes missing the spot. I can build you a newer version of the software that supports the external reflash connector but that would probably be on Monday.

-Michael

darewood
Posts: 18
Joined: Mon May 07, 2012 10:59 am

Re: Reading Rom Issues

Post by darewood » Sat Jun 02, 2012 9:07 am

That would be easier on my end :) But I can also splice if I know what pin is what. By looking at this diagram
Image
if the pin layout is the same, then pin 11 is open. So I can easily use the reflash connector pin and just place it inside the OBD pin port. Then just splice the wire into the reflash wire :)

cranswick
Posts: 124
Joined: Mon Feb 27, 2012 2:10 am

Re: Reading Rom Issues

Post by cranswick » Sun Jun 03, 2012 7:19 pm

that should work man, but i thought the adapter was so you wouldn't have to splice anything :lol: , i had similar problems with mine as well, though mine's spliced, i did have to solder the connection...

but i see you saw the other thread darewood...make sure too that the tactrix connector is making good contact, i had some problems with that when we reflashed mine with the base turbo tune...i wiggled the connector a bit, and bam! i was reading the ECU...good luck man.

darewood
Posts: 18
Joined: Mon May 07, 2012 10:59 am

Re: Reading Rom Issues

Post by darewood » Mon Jun 04, 2012 10:13 am

haha thanks Cranswick! It's a little simpler for me though. I believe all I need to do is pull out the wire from the white connector on the car, then swap the connection types from the reflash plug so that it can be easily placed into the OBD-II port. Not sure if you follow me, but I know what I mean haha.

Post Reply