Need support, Cannot write to ECU for any tunes

Any discussion related to the 4G Eclipse GT/GS
TrevRoar
Posts: 35
Joined: Mon May 21, 2012 11:40 am
Location: NY 13760
Contact:

Need support, Cannot write to ECU for any tunes

Post by TrevRoar » Mon Jun 15, 2015 4:04 pm

Hello Michael, looking for some help as soon as you can offer it.
I'm going to lay out all my issues here all at once, so we can get them resolved.

First issue, I cannot write to my ECU without doing an ECU recovery. I just tried uninstalling the software, deleted all FastWorks directories and re-installed the software and the problem remains. While deleting the directories, I permanently deleted my recovery file, so now I cannot use the software at all the write to the ECU. I can read from the ECU, and it tells me I need to upload the file to the servers in order to receive a tune. I can also read/clear codes and display the gauges without a problem. I suspect when I updated my software, and firmware to the ECU something wasn't quite right between the two, so they aren't talking to each other as they should be.

My second problem, is I can't rev my car passed 5000RPM's no matter if i'm at a standstill or driving. You had mentioned that you had built my definition file using an automatic transmission, and I'm running a 6sp manual. I'm suspecting that the launch control is the cause for this, but can't rule it out since I cannot write to me ECU to make the changes to the launch control.

Lastly, I need to modify my tune after the above to items are worked out. Please let me know when you're available for a team viewer session

Image

Image

cranswick
Posts: 124
Joined: Mon Feb 27, 2012 2:10 am

Re: Need support, Cannot write to ECU for any tunes

Post by cranswick » Fri Jun 19, 2015 10:31 pm

it's failing to read as well? can connect to the ECU?

hackish
Site Admin
Posts: 588
Joined: Wed Jan 05, 2011 1:49 pm

Re: Need support, Cannot write to ECU for any tunes

Post by hackish » Mon Jun 22, 2015 11:15 am

This seems like a software/tune support issue. Typically handled by support@fastworks.com. If you're doing an initial install then I assume you're doing an upgrade from uvtunes? In that case I have to do something to your account to make it work.

-Michael

TrevRoar
Posts: 35
Joined: Mon May 21, 2012 11:40 am
Location: NY 13760
Contact:

Re: Need support, Cannot write to ECU for any tunes

Post by TrevRoar » Thu Jun 25, 2015 12:42 pm

Not sure if you made any changes with my account, but all is working now with connecting and writing to the ECU.
However, after the upgrade, I'm getting two codes P1020 and P1022 for the Mivec controls. I have replaced the Mivec actuator, and pressure sensor, as well as installed new rockers into each cylinder head with attempts to defeat these codes. I've also toned back each terminal in the wireharness and found the harness and connectors to be good. It seems that I'm not getting any signal from the ECU. Was there any changes to the ECU in the firmware upgrade? The last step of my troubleshooting process is to replace the ECU. So I'd like to rule out any possibility that it is the firmware/tune

hackish
Site Admin
Posts: 588
Joined: Wed Jan 05, 2011 1:49 pm

Re: Need support, Cannot write to ECU for any tunes

Post by hackish » Thu Jun 25, 2015 12:56 pm

None of these things should be in any way affected. Best idea is for me to arrange a stock file so you can flash it back 100% stock. Not saying I've never made a mistake but I've never seen this issue before.

-Michael

TrevRoar
Posts: 35
Joined: Mon May 21, 2012 11:40 am
Location: NY 13760
Contact:

Re: Need support, Cannot write to ECU for any tunes

Post by TrevRoar » Thu Jun 25, 2015 1:54 pm

Lets give that a shot to rule it out. Last five of the VIN 11398
Just would need the immoblizer disabled.

hackish
Site Admin
Posts: 588
Joined: Wed Jan 05, 2011 1:49 pm

Re: Need support, Cannot write to ECU for any tunes

Post by hackish » Tue Jun 30, 2015 11:46 am

Can you request a stock file from tuning@fastworks.com? This way it can be sent to you properly.

-Michael

TrevRoar
Posts: 35
Joined: Mon May 21, 2012 11:40 am
Location: NY 13760
Contact:

Re: Need support, Cannot write to ECU for any tunes

Post by TrevRoar » Wed Sep 30, 2015 1:46 pm

Hello Michael, I sent an email as instructed above, but hasn't gotten anything back from you. Will you be emailing the tune, or does it get pushed out another way? Let me know, here is a copy of my request.

Provide a tune to support the following mods
I’m currently using version 9308, def file 1860A516DD full VIN for the vehicle is 7E011398

AEM Cold air intake P/N 21-438C MAF housing diameter 2.68”
One step colder plugs NGK Iridium IX 2667 BKR7EIX
Outlaw Engineering Thermal spacers
RRE Headers
Third cat still installed
Magnaflow Catback 2.5" exhaust
6-speed manual
Immobilizer disable

hackish
Site Admin
Posts: 588
Joined: Wed Jan 05, 2011 1:49 pm

Re: Need support, Cannot write to ECU for any tunes

Post by hackish » Mon Oct 05, 2015 10:51 am

Ticket arrived 9th of September file was sent 11th. I can re-send it if you like.

-Michael

TrevRoar
Posts: 35
Joined: Mon May 21, 2012 11:40 am
Location: NY 13760
Contact:

Re: Need support, Cannot write to ECU for any tunes

Post by TrevRoar » Tue Oct 06, 2015 8:55 pm

Please do! Thanks Michael! I'll be sure to watch for it

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests